lccee
管理员
管理员
  • UID1
  • 粉丝9
  • 关注1
  • 发帖数143
阅读:14043回复:0

Mysql启动失败的原因

楼主#
更多 发布于:2017-05-11 13:33
1、PHPWAMP的Mysql数据库启动失败,1067错误(多见于低配置服务器)
该错误的表现:PHPWAMP数据库在本地可以正常启动,在服务器上确启动失败,手动纠错出现1067错误提示。
解决方式:服务器内存小也会导致数据库启动失败(可以加官方Q群,用群文件的低配专用my.ini覆盖默认的配置),当然你可以选择设置虚拟内存,也可以升级服务器配置,一般建议用低配my.ini覆盖即可(目前新版PHPWAMP不用替换,如出现错误请查看是否是系统等其他原因引起的)


2、数据库端口被占用引起
端口占用导致的mysql启动失败,可以修改端口或者解除占用如下图。
该错误的表现:新版本phpwamp会直接提示某个位置的某个端口被占用,旧版phpwamp进度条会运行一段时间后提示失败。
解决方式:可以切换霸体模式或者清空阻碍(也可以点击主界面“查看占用端口”,查询到占用的程序后右键强制解除占用)

图片:QQ图片20170511162708.png


可以点此修改mysql的端口,当然也可以不修改直接解除占用端口即可。【点击查看如何解除占用端口】


3、路径引起的错误
禁止把PHPWAMP放在中文路径和带有空格以及括号的路径下,比如:C:\Program Files (x86)这个路径就是错误的
该错误的表现:win7到win10系统,通常软件会弹出提示,如果是早期更新的win10可能会无响应(换个路径就可以了)
中文错误路径案例:C:\Users\neptune\Desktop\新建文件夹\phpwamp(这个路径有中文)
空格和括号错误路径案例:C:\Program Files (x86)\phpwamp(这个路径有括号和空格,所以是错误的)


4、系统环境变量被修改引起的错误
还原默认的环境变量即可(系统环境变量被删掉了,也就无法确认相关路径)
该错误的表现:通常一开始点启动环境或是切换版本的时候,就会立马弹出mysql和apache启动失败的提示。
以win7为例,我们只需要在系统环境变量里设置如下/:(自行百度搜索如何恢复电脑系统的环境变量)
变量名:path
变量值:%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\


5、Apache站点管理引起的启动错误
在站点管理里面的端口出现占用、站点根目录不存在引起的启动失败
解决方式:先导出站点保存在一个地方,清空所有站点,如果清空站点后可以启动,说明站点管理里面的站点设置出现冲突,常见的就是端口相同,还有就是你设置的网站根目录压根就木有!(通常是因为移动了PHPWAMP文件夹到另外的电脑或其他位置,站点路径出现变化引起的)


6、安装扩展出现错误
解决方式:注意版本、位数、线程,只要对应好,没有啥安不上的,
很多同学安装时都说这装不上那装不上的,但是每次我去试都能装得上,所以说,这玩意得细心点!


7、杀毒软件引起的错误
解决方式:PHPWAMP已经过百度杀毒、卡巴斯基的安全验证,但是某些杀毒可能会误报,将PHPWAMP拉入白名单即可。
有些杀毒限制程序,可能造成apache等程序无法访问,请拉到软件白名单即可。
杀毒软件如果弹出提示,记得勾选“不再提醒”和“允许全部”


8、修改配置文件引起的错误

修改配置的时候,因为自己不熟悉造成的修改错误,环境就启动失败了,记得修改之前自己备份好,网上很多的配置教程有的是错误的,毕竟不同的版本在不同的情况下,配置是有所差别的,而且各个配置也是相互影响的。


9、电脑系统引起的错误
windows 2003服务器和XP系统其实是同样的内核,php官方发布php5.5的时候已经表示不在支持
所以PHP 5.5 以上的版本并不支持Windows XPWindows 2003 系统,最高只能使用PHP5.4.

因为Apache2.2本身也是无法支持5.5以上的PHP的,php5.5以上的版本必须要运行在Apache2.4上面。
所以Windows 2003用户只能使用PHPWAMP中的apache2.2站点管理,最高只能支持php5.4版本,需要更高的php版本必须升级系统

其他相关错误汇总(点击查看)    如有疑问请加入官方QQ群
游客

返回顶部